EOC Online requires that you are using Internet Explorer 5 or above, with Macromedia Flash 5 plug-in and Microsoft Windows Media Video 8. If you have the above browser with ActiveX controls enabled your browser will automatically install the correct requirements for the game. You may be prompted to accept downloads from Macromedia and Microsoft - you must accept these to allow the plug-ins to be correctly installed.

 

 

 

The tests below will try and detect your compatibility with EOC Online:
Browser - requires Internet Explorer 5 or above.
We have detected that you do not have the correct browser for EOC Online, although you may still be able to play EOC Online, it may not display as expected.

Flash Plug-In - requires Macromedia Flash 5. If you can see the logo below then Flash 5 is installed.

If you cannot see the logo - click here.

Microsoft Windows Media Video 8 Codec is required. If you can see the logo below then the plug-in is correctly installed.

If you cannot see the logo - click here. (This will take you to a link to the latest version of Microsoft Media Player, which includes the Windows Media Video 8 codec.)